Jump to content
SuperStickman

Bugs / Glitches etc.

Recommended Posts

UUalrus    0

Hey @Arlin

DLC courses aren't counting towards the stats in the setting menu. 

I realized this when I got the achievement for 100 swishes when it says I only have 51. Then I did some testing, and downloaded courses doesn't count toward stokes or powerups and I assuming all DLC doesn't count towards the stats whatsoever

-Andy

Share this post


Link to post
Share on other sites
Nicky141    0

Hi,

 

I appear to be having trouble with one of the new trophies. I don't know if it's a bug or an error on my end but I'm trying to complete the new 'splish' trophy which requires a swish off a 'water bounce'. I've tried this two ways, both on hole 5 of magnet sub. First try was using the shield ball power up to get the 'water bounce' and the second attempt was using the sea captain hat. Each time I got a swish but I still haven't been awarded the trophy. 

 

Any help would be great!

Thanks,

Nicky

Share this post


Link to post
Share on other sites
Cyberwolf    0

Since the last update my SSG 3 isn't functioning anymore.
After starting the game it just shows a blank screen with the moving background picture. When I touch anywhere it opens the dialog for daily races, but i there is just the text and nothing else, no buttons or other graphics. So i am completely unable to do anything but closing the game.

I tryed to uninstall and reinstall again, nothings changed.

I am using a Nexus 7 (2012) with an old CyanogenMod Version and Android 4.3.1 (was the most stable version for me).

Share this post


Link to post
Share on other sites
NoodleDerek    1
On 2017-01-29 at 1:13 PM, Cyberwolf said:

Since the last update my SSG 3 isn't functioning anymore.
After starting the game it just shows a blank screen with the moving background picture. When I touch anywhere it opens the dialog for daily races, but i there is just the text and nothing else, no buttons or other graphics. So i am completely unable to do anything but closing the game.

I tryed to uninstall and reinstall again, nothings changed.

I am using a Nexus 7 (2012) with an old CyanogenMod Version and Android 4.3.1 (was the most stable version for me).

Can you upload a screenshot of what that looks like?

Share this post


Link to post
Share on other sites

So, is there any hope for all of us that can't play race mode because of the "Failed to find players" issue that has been reported over and over?  Race mode was my favorite part of SSG2, and now I can't play it on SSG2 or SSG3.  It's also annoying that so many achievements are tied to a part of the game that is inaccessible for so many of us.

Share this post


Link to post
Share on other sites
Caddyshaq    3

I'm sure others have experienced this... it has to be a cheat, right? I was playing a turn based game, and my opponent's ball went in the water on stroke six. Then I got a "replay error" message, and he was credited with a score of five for that hole. I've lost count of how many times this has happened, and I don't believe this is a game glitch, but an intentional score cheat...

Screenshot_2017-02-09-09-27-41.png

Screenshot_2017-02-09-09-27-47.png

Share this post


Link to post
Share on other sites
OxfordRob    3

Hello... Is there something not quite right with the SSMG3 server/s as the last couple of days I have been constantly getting it flake out on me trying to take part in turn based games. Over a solid working 3G connection it connects for about a minute and then hangs up. Wifi is fine. In the next couple of days I am moving to a 4g capable iphone SE so hope when out and about it will be better. Is there something that can be done to stop this though? Having done virtually all medals and everything else there is I rely loads on turn based games.

Share this post


Link to post
Share on other sites
Cyberwolf    0
On 6.2.2017 at 9:32 PM, NoodleDerek said:

Can you upload a screenshot of what that looks like?

Hey there, sorry for not responding on your post, last time. After my last bug-report, the problem was fixed with the next minor update, so i did not look in here again.

After the last major update i got the same problem again.

When taking screenshots directly on my tablet, SSG3 is crashing and nothing is visible on the screenshot, so i took some "screenshots" with the camera of my smartphone. Please excuse the bad quality of those pictures.IMG_20170420_004909.thumb.jpg.13a443af9ff62e4f09d5d2fb6c8b5e84.jpg

IMG_20170420_005001.thumb.jpg.70dce6551fbb5f2c50c632d95caf3151.jpg

IMG_20170420_005050.thumb.jpg.99c3ee66e6c44bb5ef464f9b8185844b.jpg

Edited by Cyberwolf

Share this post


Link to post
Share on other sites
schveiguy    0

On iOS version 1.7.7, my game crashes. A lot. No specific time/activity, it can crash at any time. First screen freezes, then audio gets crackly and then crash.

Annoying thing is that if you are doing turn based multiplayer, it counts any strokes you had taken up to that point, and then you have to start the hole over. So for example if you are 2 strokes into the hole, and a crash occurs, you then start out at the beginning +2.

The crashing makes multiplayer racing terrible as well.

I had experienced sporadic crashes before this update, but this update seems to have made it much much worse. Let me know if you need anything specific from me, or want me to try a debug build, etc.

Share this post


Link to post
Share on other sites
schveiguy    0
On 2/9/2017 at 9:35 AM, Caddyshaq said:

I'm sure others have experienced this... it has to be a cheat, right? I was playing a turn based game, and my opponent's ball went in the water on stroke six. Then I got a "replay error" message, and he was credited with a score of five for that hole. I've lost count of how many times this has happened, and I don't believe this is a game glitch, but an intentional score cheat...

This isn't a cheat. I see this happen when I play against my friends, and I watch their play on their device. I think what happens is the replay is sent as a series of timed activations of button presses, and possibly the difference in the timing or floating point error causes the physics engine to replay it differently on your device.

To Noodlecake: it may be useful to put periodic absolute state messages in the replay data (i.e. at this point the ball should bounce off this wall with this momentum, etc.) so the replay can always be accurate. It may have weird replay artifacts such as the ball jumping slightly, but would look better than the ball just going into the water or not going into the hole when it actually did.

Share this post


Link to post
Share on other sites

On Android 7.1.2 (Nexus 6P), I'll run into a bug where SSG3's music will keep playing even after I switch to another app or go to sleep/rest mode. This doesn't happen every time but I'd say between 60-70% of the time I play. Doesn't seem dependent on course, as it's happened on multiple courses, both downloaded and regular, as well as from the main menu. Whenever this happens, I have to force quit SSG3 to get it to stop.

Share this post


Link to post
Share on other sites
NoodleDerek    1

Hey guys,

Thanks for the bug reports, we do read and track these issues even if we don't always have time to respond to the post!

Just wanted to say thanks for helping us make the game better!

Share this post


Link to post
Share on other sites

Hello, I have a problem with daily race, because it' s reset every day :(

in 10 days, I can play for 5bux just 2 times.

And yesterday, on the 5 try, it's allways the same player to win, but if he win, what is here again for the next try ?

Share this post


Link to post
Share on other sites
1089maths    1

Hey @NoodleDerek and @Arlin,

When I recently synced my SSG3 progress from my mid-2011 MacBook Air to my 2015 MacBook Air, all of the content of the game was lost. Apart from the trophies that I received. Then, I downloaded the game onto my iPhone and the same thing happened: just the trophies were saved.

Could you please help me with this as I have nearly beaten the game and would not like starting from scratch again.

Edited by 1089maths
@ symbols

Share this post


Link to post
Share on other sites
JustyW23    0

Hi, can anyone help? I recently installed the app update on my iPad2 and now the courses are all corrupted. It's as if the background has separated from the player. The courses can still be played but it's guesswork as to where to aim etc!

 

image.png

image.png

image.png

Share this post


Link to post
Share on other sites
1089maths    1

I have a whole bunch of glitches here, including sticky walls, swishes, loading screens and lasers.

@JustyW23 - a fix is coming out soon.

Hi, can anyone help? I recently installed the app update on my iPad2 and now the courses are all corrupted. It's as if the background has separated from the player.

Edited by 1089maths

Share this post


Link to post
Share on other sites
Caddyshaq    3

I was wondering if there's a way to tell if my referral code is working? I've posted it a couple times on here, and my posts are being viewed but the code isn't being redeemed. Any help would be appreciated

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×