Jump to content
oen Coen

Game Freezes after the ball hits the hole

Recommended Posts

Is it my Samsung SM-T520, Android 4.4.2? I can hardly finish a course without the game freezing at the moment the ball drops in the hole. Usually this happens at the last hole (9), but sometimes also at other holes. If this happens the only thing I can do is kill the game. I have removed and reinstalled ssg3 many times, but that does not help. Turn Based games are therefore unplayable, because if I want to play the course again after the crash, I start with the score I had on the moment of the crash. I hope that there is a solution, because I like ssg3 very much. For the time being, however, I started to play ssg2 again, and that one works perfectly.

Share this post

Link to post
Share on other sites

Hey Ben,

Sorry for the troubles. That's not an issue we're aware of. I just played through a couple courses on an Android 4.4.2 Note 2 and couldn't recreate the problem.

Sounds like you've already tried some troubleshooting but unfortunately unless we can recreate the problem on other devices it's really hard for us to fix a problem like that.


Here are few things you can try if you haven't already.

1. Force close the app and trying restarting it.

To force close the app, open System Settings → Applications → SSG3  → 'Force Stop'  (Note: The menu options might be slightly different on your device). Alternatively, open the app switcher and swipe to fully close the application.

2. Power cycle (restart) your device

Generally you can restart the device by holding down the power button until options to power off or restart pop up.

3. Please ensure you are using the latest version of the app. 

To check for updates, open the Google Play Store and search for the app. If a button to “update” is available, tap it to update the app to the latest version.

4. Ensure your device storage is not full. 

To check how much storage you have left on your device head to System Settings → Storage. If you device has less than 10% free space, delete some unused apps, videos or files to make a little extra breathing room. Android can tend to do strange things when the internal storage is nearly full.

5. Try clearing the app cache

Go to System Settings → Applications → SSG3 → Storage → “Clear Cache” (do not "Clear data" or you may lose your progress). Then launch the game, you may need to sign into Google Play Games again.

6. Try closing any background applications

Open the app switcher and swipe to close any other running applications.

7. If those steps do not resolve the issue, please uninstall the game and reinstall it from the Google Play Store.

Note: On some games without cloud save this will delete your progress. You can uninstall the game by long-pressing on the game icon then dragging the icon to the “uninstall” location on the upper right hand corner of the screen (on some versions of Android). You can also uninstall by going to System Settings → Applications → SSG3 → Uninstall. Then head back to the Play Store to re-install the game.

Share this post

Link to post
Share on other sites

Hi Derek, thank you very much for your quick and comprehensive answer. I'm going to try all your tips. So far I have only cleared the cache and closed all background applications and then played Gravity Lab, but at the last hole the game got stuck again. Could it be that at that moment the game wants to save my score on Google games and that something goes wrong there? I will keep you informed of my further experiments. thanks again! Oh and bye the way, according to Google Play Store I have the latest version (1.7.20) and I have checked my device storage: 5.96 GB free from 16 GB on the device itself and 28 GB free from 29 GB on my sd cart.

Share this post

Link to post
Share on other sites

Hi Derek,

I am cautiously optimistic. Force stopping the game via "open System Settings → Applications → SSG3  → Force Stop" after playing seems to help. Freezing still happens occasionally, but much less often. Incidentally, something that struck me: I also tried to move the game from my SD-Card to the device storage and then my tablet rebooted spontaneously. However, this did not help, so I moved the game back on the SD-Card and that happened without a reboot of my device.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...